`
Simone_chou
  • 浏览: 184691 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

More is better(并查集)

    博客分类:
  • HDOJ
 
阅读更多

 

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 10355    Accepted Submission(s): 3814

Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
Sample Input
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8
Sample Output
4
2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

    题意:

    给出n种朋友关系,在这么多堆朋友圈中,输出最多人数一组的人数。

    思路:

    并查集。增加一个数组rank来统计某个节点下面有多少人,合并的时候累加一层即可。

    AC:

#include<stdio.h>
#define max 10000000
int root[max],rank[max];
int find(int a)
{
	int x=a,t;
	while(root[x]!=x)
	  x=root[x];
	while(x!=a)
	 {
	 	t=root[a];
	 	root[a]=x;
	 	a=t;
	 }
	return x;
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		int a,b,m=0,sum=1;
		for(int i=1;i<max;i++)
		 {
		 	root[i]=i;
		 	rank[i]=1;
		 }
		while(n--)
		{
			int fa,fb;
			scanf("%d%d",&a,&b);
			fa=find(a);
			fb=find(b);
			if(a>sum) sum=a;
			if(b>sum) sum=b;
			if(fa==fb) continue;
			else
			{
				rank[fb]+=rank[fa];
//只需要增加这一句,来求叠加人数
				root[fa]=fb;
			}
			
		}
		for(int i=1;i<=sum;i++)
		  if(rank[i]>m) m=rank[i];
//查找rank中最大值即为所求
		printf("%d\n",m);
	}
	return 0;
}

   总结:

   看清题目,不要钻牛角尖。

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics