`
Simone_chou
  • 浏览: 185208 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

Ubiquitous Religions(并查集)

    博客分类:
  • POJ
 
阅读更多
Ubiquitous Religions
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 20788   Accepted: 10212

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 
You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended.
   题意:   
   给出N(0到50000)个同学,M种关系,判断一共有多少堆同学圈。 
   思路:   
   给出关系求有多少个集合。简单并查集。
AC:
#include<stdio.h>
#define max 50000
int root[max];
int find(int a)
{
	int x=a,t;
	while(x!=root[x])
	  x=root[x];
	while(x!=a)
	{
		t=root[a];
		root[a]=x;
		a=t;
	}
	return x;
}
int main()
{
	int n,m,time=0;
	while(scanf("%d%d",&n,&m)!=EOF&&(n||m))
	{
		int ans=0;
		time++;
		for(int i=1;i<=n;i++)
		   root[i]=i;
		while(m--)
		{
			int a,b;
			int fa,fb;
			scanf("%d%d",&a,&b);
			fa=find(a);
			fb=find(b);
			if(fa!=fb)  root[fa]=fb;
		}
		for(int i=1;i<=n;i++)
		 if(root[i]==i) ans++;
		printf("Case %d: %d\n",time,ans);
	}
	return 0;
}
    总结:
    简单并查集,跟之前做过的类型一样,当复习一遍。
分享到:
评论
2 楼 Simone_chou 2013-08-21  
沙茶敏 写道
只是来看你是不是在熬夜

当然不是。哈哈
1 楼 沙茶敏 2013-08-21  
只是来看你是不是在熬夜

相关推荐

Global site tag (gtag.js) - Google Analytics