`
Simone_chou
  • 浏览: 185315 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

Dividing(多重背包)

    博客分类:
  • POJ
 
阅读更多
Dividing
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 54064   Accepted: 13818

Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1 2 0 0". The maximum total number of marbles will be 20000. 
The last line of the input file will be "0 0 0 0 0 0"; do not process this line.

Output

For each collection, output "Collection #k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.". 
Output a blank line after each test case.

Sample Input

1 0 1 2 0 0 
1 0 0 0 1 1 
0 0 0 0 0 0 

Sample Output

Collection #1:
Can't be divided.

Collection #2:
Can be divided.

 

    题意:

    有6种大理石,给出每种大理石的数量和价值,用num[ i ](不超过20000)表示,i 代表价值,num[ i ]代表数量。判断是否能平均分成两堆价值一样的大理石。

 

    思路:

    多重背包。

 

    AC1:

#include<stdio.h>
#include<string.h>
#define max 1000000
int dp[500000],val[50000];

int main()
{
    int num[11],time=1;
    while(scanf("%d%d%d%d%d%d",&num[1],&num[2],&num[3],&num[4],&num[5],&num[6])!=EOF)
    {
      int sum=0,half,k=0;
      dp[0]=0;
      for(int i=1;i<500000;i++)
        dp[i]=-max;
      for(int i=1;i<=6;i++)
        sum+=num[i]*i;
      if(!sum) break;
      printf("Collection #%d:\n",time++);
      if(sum%2)  printf("Can't be divided.\n\n");
      else
      {
        half=sum/2;
        for(int i=1;i<=6;i++)
        {
         for(int j=1;j<=num[i];j++)
           val[k++]=j*i,num[i]-=j;
         if(num[i]>0)
           val[k++]=num[i]*i;
        }
        for(int i=0;i<k;i++)
         for(int j=half;j>=val[i];j--)
          if(dp[j-val[i]]+val[i]>dp[j])
          dp[j]=dp[j-val[i]]+val[i];
        if(dp[half]<0) printf("Can't be divided.\n\n");
        else printf("Can be divided.\n\n");
      }
    }
    return 0;
}

 

AC2比AC1要更省时间。

 

    AC2:

#include<stdio.h>
#include<string.h>
#define max 1000000
int sum,half;
int dp[200000];

void zeroonepack(int value)
{
    for(int i=half;i>=value;i--)
      if(dp[i]<dp[i-value]+value)
      dp[i]=dp[i-value]+value;
}

void completepack(int value)
{
    for(int i=value;i<=half;i++)
      if(dp[i]<dp[i-value]+value)
      dp[i]=dp[i-value]+value;
}

void multipack(int value,int number)
{
    int k=1;
    if(value*number>half)
     completepack(value);
    while(k<number)
    {
     zeroonepack(k*value);
     number-=k;
     k+=k;
    }
    zeroonepack(number*value);
}

int main()
{
    int num[10];
    int time=1;
    while(scanf("%d%d%d%d%d%d",&num[1],&num[2],&num[3],&num[4],&num[5],&num[6])!=EOF)
    {
     sum=0;
     dp[0]=0;
     for(int i=1;i<=6;i++)
       sum+=num[i]*i;
     if(!sum) break;
     printf("Collection #%d:\n",time++);
     if(sum%2) printf("Can't be divided.\n\n");   
//如果总价值为单数的时候,无论怎么分都不可能分成平均的两份
     else
     {
      for(int i=1;i<200000;i++)
        dp[i]=-max;
      half=sum/2;
      for(int i=1;i<=6;i++)   //是每一个数都要进行一次01背包
        multipack(i,num[i]);
      if(dp[half]<0) printf("Can't be divided.\n\n");   //输出格式注意
      else printf("Can be divided.\n\n");
     }
    }
    return 0;
}

 

    总结:

    1.输出格式没看清;

    2.总数为单数的情况没考虑仔细;

    3.注意数组开的大小。

 

 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics