`
Simone_chou
  • 浏览: 185257 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

Corporate Identity(KMP)

    博客分类:
  • POJ
 
阅读更多

 

 

Corporate Identity
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 4391   Accepted: 1668

Description

Beside other services, ACM helps companies to clearly state their “corporate identity”, which includes company logo but also other signs, like trademarks. One of such companies is Internet Building Masters (IBM), which has recently asked ACM for a help with their new identity. IBM do not want to change their existing logos and trademarks completely, because their customers are used to the old ones. Therefore, ACM will only change existing trademarks instead of creating new ones.

After several other proposals, it was decided to take all existing trademarks and find the longest common sequence of letters that is contained in all of them. This sequence will be graphically emphasized to form a new logo. Then, the old trademarks may still be used while showing the new identity.

Your task is to find such a sequence.

Input

The input contains several tasks. Each task begins with a line containing a positive integer N, the number of trademarks (2 ≤ N ≤ 4000). The number is followed by N lines, each containing one trademark. Trademarks will be composed only from lowercase letters, the length of each trademark will be at least 1 and at most 200 characters.

After the last trademark, the next task begins. The last task is followed by a line containing zero.

Output

For each task, output a single line containing the longest string contained as a substring in all trademarks. If there are several strings of the same length, print the one that is lexicographically smallest. If there is no such non-empty string, output the words “IDENTITY LOST” instead.

Sample Input

3
aabbaabb
abbababb
bbbbbabb
2
xyz
abc
0

Sample Output

abb
IDENTITY LOST

Source

 

    题意:

    给出N( 2 ≤ N ≤ 4000),代表有N个字符串,后给出这N个字符串,每个字符串str长度为1~200。输出这N个字符串最大长度的公共子串,如果有相同长度的则输出字典序最小的子串。

 

    思路:

    KMP。以第一个串为标准,列出所有的子串,对每个子串对剩下的 N - 1个串进行匹配,都能匹配成功后,判断长度,最后再判断字典序即可。

    

    AC:

#include<stdio.h>
#include<string.h>
char str[4005][205];
char p[205],fin[205];
int n,maxnum;
int next[205];

int test()  //长度相同时判断字典序
{
    for(int i = 0;i < maxnum;i++)
    {
        if(p[i] > fin[i]) return 0;
        if(p[i] < fin[i]) return 1;
    }
}

void get_next(int len)  //取得next值
{
    int i = 0,j = -1;
    next[0] = -1;
    while(i < len)
    {
        if(j == -1 || p[i] == p[j]) next[++i] = ++j;
        else                        j = next[j];
    }
}

int kmp()   //KMP匹配
{
    for(int k = 2;k <= n;k++)
    {
        int len1 = strlen(str[k]),len2 = strlen(p);
        int i = 0,j = 0;
        while(i < len1 && j < len2)
        {
            if(j == -1 || str[k][i] == p[j])
            {
                i++;
                j++;
            }
            else    j = next[j];
        }
        if(j != len2) return 0;
    }
    return 1;
}

int main()
{
    while(scanf("%d",&n) != EOF && n)
    {
        maxnum = 0;
        for(int i = 1;i <= n;i++)
            scanf("%s",str + i);
        for(int i = 0;i < strlen(str[1]);i++)
            for(int j = 1;j <= strlen(str[1]) - i;j++)
        {
            int len;
            memset(p,0,sizeof(p));
            memset(next,0,sizeof(next));
            strncpy(p,str[1] + i,j);   //复制串到匹配串
            len = strlen(p);
            get_next(len);
            if(kmp())
            {
                if(len > maxnum)
                {
                    maxnum = len;
                    strcpy(fin,p);   //复制到最终输出串
                }
                if(len == maxnum && test())  strcpy(fin,p);
            }
        }
        if(!maxnum) printf("IDENTITY LOST\n");
        else        puts(fin);
    }
    return 0;
}

 

   

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics