`
Simone_chou
  • 浏览: 184880 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

Stockbroker Grapevine(最短路 + Dijkstra + 邻接表 + 优先队列)

    博客分类:
  • POJ
 
阅读更多
Stockbroker Grapevine
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 24988   Accepted: 13771

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

 

    题意:

    给出 N(1 ~ 100),说明有 N 个节点,后按顺序 1 到 N 给出该节点与其他节点的关系状况,每条关系首先给出数字 M,代表 i 节点有 M 个出度,后给出 入节点 和 时间。比如 2 2 3 3 5,说明 i 节点出发有两个节点,分别是 2 和 3,到 2 的时间为 3 ,到 3 的时间为 5 。选择一个节点同时发出信息,使发送的时间最短。输出这个节点和花费的总时间,如果找不到则输出“disjoint”。

 

    思路:

    最短路。Dijkstra + 邻接表 + 优先队列。对于每个节点都求一次单源最短路后,找到需要花费最长的时间,如果这个节点有某一点不能达到,说明这个节点不能作为起点。如果都不能作为起点则输出 disjoint 。

 

    AC:

#include <cstdio>
#include <vector>
#include <queue>
#include <utility>
#include <iostream>
#include <string.h>
#define MAX 10000
#define INF 99999999
using namespace std;

typedef pair<int,int> pii;

int v[MAX],fir[105],next[MAX],w[MAX];
int d[105],vis[105];
int n,ind;

void add_edge(int f,int t,int val) {
    v[ind] = t;
    w[ind] = val;
    next[ind] = fir[f];
    fir[f] = ind;
    ind++;
}

int Dijkstra(int sta) {
    int max_time = -1;
    for(int i = 1;i <= n;i++) d[i] = INF;
    memset(vis,0,sizeof(vis));
    d[sta] = 0;
    priority_queue<pii,vector<pii>,greater<pii> > q;
    q.push(make_pair(d[sta],sta));
    while(!q.empty()) {
        pii k = q.top();q.pop();
        int x = k.second;
        if(vis[x]) continue;
        vis[x] = 1;
        for(int e = fir[x];e != -1;e = next[e]) {
            int y = v[e];
            if(d[y] > d[x] + w[e]) {
               d[y] = d[x] + w[e];
               q.push(make_pair(d[y],y));
            }
        }
    }

    for(int i = 1;i <= n;i++) {
        if(i == sta) continue;
        if(d[i] == INF) return -1;
        if(d[i] > max_time) max_time = d[i];
    }

    return max_time;
}

int main() {
    //freopen("test.in","r",stdin);
    int max_time,max_idx;
    while(~scanf("%d",&n) && n) {
        ind = 0;
        max_time = INF;
        memset(fir,-1,sizeof(fir));
        for(int i = 1;i <= n;i++) {
            int num;
            scanf("%d",&num);
            while(num--) {
                int a,val;
                scanf("%d%d",&a,&val);
                add_edge(i,a,val);
            }
        }

        for(int i = 1;i <= n;i++) {
            int time = Dijkstra(i);
            if(time != -1 && time < max_time) {
                max_time = time;
                max_idx = i;
            }
        }

        if(max_time == INF) puts("disjoint");
        else    printf("%d %d\n",max_idx,max_time);
    }
    return 0;
}

 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics