`
Simone_chou
  • 浏览: 184757 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

The Perfect Stall(二分图最大匹配 + 匈牙利算法)

    博客分类:
  • POJ
 
阅读更多
The Perfect Stall
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 17260   Accepted: 7878

Description

Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall. 
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible. 

Input

The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.

Output

For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.

Sample Input

5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2 

Sample Output

4

 

    题意:

    给出 N (0 ~ 200)头牛和 M (0 ~ 200)个地方。每头牛都有自己中意的地方,并且只会在自己中意的地方生产。后给出 这 N 头牛喜欢的地方,首先给出一个个数 T,后给出这 T 个地方。问如何匹配使最大数量的牛能够生产。

 

    思路:

    二分图最大匹配。匈牙利算法。

 

    AC:

#include <cstdio>
#include <string.h>
using namespace std;

int vn,un;
int w[205][205];
int vis[205],linker[205];

bool dfs(int u) {
    for(int v = 1;v <= vn;v++)
        if(w[u][v] && !vis[v]) {
            vis[v] = 1;
            if(linker[v] == -1 || dfs(linker[v])) {
                linker[v] = u;
                return true;
            }
        }

    return false;
}

int hungary() {
    int res = 0;
    memset(linker,-1,sizeof(linker));

    for(int u = 1;u <= un;u++) {
        memset(vis,0,sizeof(vis));
        if(dfs(u))  res++;
    }

    return res;
}

int main() {
    while(~scanf("%d%d",&un,&vn)) {
        memset(w,0,sizeof(w));
        for(int i = 1;i <= un;i++) {
            int num;
            scanf("%d",&num);
            while(num--) {
                int ans;
                scanf("%d",&ans);
                w[i][ans] = 1;
            }
        }

        printf("%d\n",hungary());
    }
    return 0;
}

 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics