`
Simone_chou
  • 浏览: 183970 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

Sum of Consecutive Prime Numbers(素数筛选 + 枚举)

    博客分类:
  • POJ
 
阅读更多
Sum of Consecutive Prime Numbers
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 17954   Accepted: 9863

Description

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime 
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20. 
Your mission is to write a program that reports the number of representations for the given positive integer.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

Sample Input

2
3
17
41
20
666
12
53
0

Sample Output

1
1
2
3
0
0
1
2

 

    题意:

    给出数 N(2 ~ 10000),输出多少种不同的组合数,能由连续素数加和所得。

 

    思路:

    素数筛选。离线处理好所有数据,筛选出10000内的素数,另开个数组保存素数,后枚举连续素数即可。    

 

    AC:

#include <cstdio>
#include <string.h>
#define MAX 10005
using namespace std;

int n,ans;
int pri_num[MAX],time[MAX];
bool pri[MAX];

void make_pri() {
    for(int i = 0;i < MAX;i++) pri[i] = true;
    pri[0] = pri[1] = false;

    for(int i = 2;i * i <= MAX;i++)
            if(pri[i]) {
                    for(int j = i;j * i <= MAX;j++)
                            pri[i * j] = false;
            }

    ans = 0;
    for(int i = 0;i < MAX;i++)
            if(pri[i])  pri_num[ans++] = i;

    memset(time,0,sizeof(time));
    for(int i = 2;i < MAX;i++) {
            for(int j = 0;j < ans;j++) {
                    int sum = 0;
                    if(pri_num[j] > i) break;
                    for(int from = j;from < ans;from++) {
                            sum += pri_num[from];
                            if(sum > i) break;
                            if(sum == i) {
                                    time[i]++;
                                    break;
                            }
                    }
            }
    }
}

int main() {
    make_pri();

    while(~scanf("%d",&n) && n) {
            printf("%d\n",time[n]);
    }

    return 0;
}

 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics