`
Simone_chou
  • 浏览: 183892 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

Apple Catching(DP)

    博客分类:
  • POJ
 
阅读更多
Apple Catching
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7076   Accepted: 3453

Description

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds. 

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples). 

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.

Input

* Line 1: Two space separated integers: T and W 

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.

Output

* Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input

7 2
2
1
1
2
2
1
1

Sample Output

6

Hint

INPUT DETAILS: 

Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice. 

OUTPUT DETAILS: 

Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.
 

       题意:

       给出 T(1 ~ 1000),W(1 ~ 30),代表有 T 秒,允许走的步数是 W。一共有两棵树,1 和 2 ,每秒中都会有其中一棵树掉苹果下来。后给出这 7s 内掉的分别是哪棵树,问在 W 秒内,最多能接到几个苹果。输出这个数。

 

       思路:

       DP。设 dp [ i ] [ j ] [ k ] 代表 i 秒时候的 j 步内于 k 号数能接到的最大苹果数。所以有两种情况:

       dp [ i ] [ j ] [ 1 ] = max ( dp [ i - 1 ] [ j ] [ 1 ] , dp [ i - 1 ] [ j - 1 ] [ 2 ] ) + tree1 [ i ] ;

       dp [ i ] [ j ] [ 2 ] = max ( dp [ i - 1 ] [ j ] [ 2 ] , dp [ i - 1 ] [ j - 1 ] [ 1 ] ) + tree2 [ i ] ;

       初始化要初始 j = 0 即步数为 0 时候的。

 

       AC:

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <iostream>

using namespace std;

const int MAX = 1005;

int tree1[MAX], tree2[MAX];
int dp[MAX][35][5];

int main () {
        int t, w;
        scanf("%d%d", &t, &w);
        memset(tree1, 0, sizeof(tree1));
        memset(tree2, 0, sizeof(tree2));

        for (int i = 1; i <= t; ++i) {
                int ans;
                scanf("%d", &ans);
                if (ans == 1) tree1[i] = 1;
                else tree2[i] = 1;
        }

        for (int i = 1; i <= t; ++i) {
                dp[i][0][1] = dp[i - 1][0][1] + tree1[i];
                dp[i][0][2] = 0;
        }

        for (int i = 1; i <= t; ++i) {
                for (int j = 1; j <= w; ++j) {
                        dp[i][j][1] = max(dp[i - 1][j - 1][2], dp[i - 1][j][1]) + tree1[i];
                        dp[i][j][2] = max(dp[i - 1][j - 1][1], dp[i - 1][j][2]) + tree2[i];
                }
        }

        printf("%d\n", max(dp[t][w][1], dp[t][w][2]));
        return 0;
}

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics