`
Simone_chou
  • 浏览: 185288 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

Sliding Window(RMQ)

    博客分类:
  • POJ
 
阅读更多
Sliding Window
Time Limit: 12000MS   Memory Limit: 65536K
Total Submissions: 35974   Accepted: 10648
Case Time Limit: 5000MS

Description

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is [1 3 -1 -3 5 3 6 7], and k is 3. Window position Minimum value Maximum value
[1  3  -1] -3  5  3  6  7  -1 3
 1 [3  -1  -3] 5  3  6  7  -3 3
 1  3 [-1  -3  5] 3  6  7  -3 5
 1  3  -1 [-3  5  3] 6  7  -3 5
 1  3  -1  -3 [5  3  6] 7  3 6
 1  3  -1  -3  5 [3  6  7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

 

      题意:

      给出 N(1 ~ 10 ^ 6) 和 K,后给出 N 个数,滑动窗口的宽度为 K,说明每次只能看到 K 个数,窗口从左滑到右,输出每次滑动的最小值和最大值。

 

      思路:

      RMQ。维护区间的最小值 和 最大值。求区间最值问题。O(n log n)的预处理 + O(1)的查询。但是用二维数组保存的话会 MLE,所以要优化一下空间,RMQ更新长度更新到 k 长度的 ans( 2 ^ ans <= k) 即可,不需要更新完全部的长度 n 长度的 ans 值(2 ^ ans <= n),这样的话,可以省略掉第二维来节省空间。

 

      AC:

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int MAX = 1000005;

int n, k, ans;
int Min[MAX], Max[MAX];

void RMQ_init() {
        for (int j = 1; j <= ans; ++j) {
                for (int i = 0; i + (1 << j) - 1 < n; ++i) {
                        Max[i] = max(Max[i], Max[i + (1 << (j - 1))]);
                        Min[i] = min(Min[i], Min[i + (1 << (j - 1))]);
                }
        }
}

int main () {

        while (~scanf("%d%d", &n, &k)) {
                ans = 0;

                for (int i = 0; i < n; ++i) {
                        scanf("%d", &Min[i]);
                        Max[i] = Min[i];
                }

                while ((1 << (ans + 1)) <= k) ++ans;
                RMQ_init();

                for (int i = 0; i <= n - k; ++i) {
                        printf("%d", min(Min[i], Min[i + k - (1 << ans)]));
                        i == (n - k) ? printf("\n") : printf(" ");
                }
                for (int i = 0; i <= n - k; ++i) {
                        printf("%d", max(Max[i], Max[i + k - (1 << ans)]));
                        i == (n - k) ? printf("\n") : printf(" ");
                }
        }

        return 0;
}

 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics