`
Simone_chou
  • 浏览: 182728 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

Rescue The Princess(数学)

 
阅读更多

Problem A:Rescue The Princess

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
<!--[if !supportLineBreakNewLine]-->
<!--[endif]-->

 

Problem Description

      Several days ago, a beast caught a beautiful princess and the princess was put in prison. To rescue the princess, a prince who wanted to marry  the princess set out immediately. Yet, the beast set a maze. Only if the prince find out the maze’s exit can he save the princess.

       Now, here comes the problem. The maze is a dimensional plane. The beast is smart, and he hidden the princess snugly. He marked two coordinates of an equilateraltriangle in the maze. The two marked coordinates are A(x1,y1) and B(x2,y2). The third coordinate C(x3,y3) is the maze’s exit. If the prince can find out the exit, he can save the princess. After the prince comes into the maze, he finds out the A(x1,y1) and B(x2,y2), but he doesn’t know where the C(x3,y3) is. The prince need your help. Can you calculate the C(x3,y3) and tell him?

 

Input

       The first line is an integer T(1 <= T <= 100) which is the number of test cases. T test cases follow. Each test case contains two coordinates A(x1,y1) and B(x2,y2), described by four floating-point numbers x1, y1, x2, y2( |x1|, |y1|, |x2|, |y2|<= 1000.0).

Please notice that A(x1,y1) and B(x2,y2) and C(x3,y3) are in an anticlockwise direction from the equilateral triangle. And coordinates A(x1,y1) and B(x2,y2) are given by anticlockwise.

 

Output

       For each test case, you should output the coordinate of C(x3,y3), the result should be rounded to 2 decimal places in a line.

 

Sample Input

4

-100.00 0.00 0.00 0.00

0.00 0.00 0.00 100.00

0.00 0.00 100.00 100.00

1.00 0.00 1.866 0.50

 

Sample Output

(-50.00,86.60)

(-86.60,50.00)

(-36.60,136.60)

(1.00,1.00)

  

 

       题意:

       给出 T,代表有 T(1 ~ 100) 个 Test。每个 Test 给出 x1,y1 ,x2,y2,(绝对值 <= 1000)代表等边三角形的其中两个点,要求输出这个等边三角形第三个点的坐标,逆时针方向。

 

       思路:

       数学。求出两个点的终点坐标 (a,b)故可以得出方程,设给出两点构成的直线斜率为 k,与该指向垂直并经过(a,b)点的直线为 k1,等边三角形边长为 d:

       r = sqrt(3) * d / 2;

       k = (y1 - y2) / (x1 - x2);

       k * k1 = -1;

       (x3 - a)^ 2 + (y3 - b)^ 2 = r ^ 2;

      (y3 - b)/ (x3 - a) = k1;

       由这些式子即可得出 x3,y3。并且对 x1 == x2 和 y1 == y2 进行另外讨论。

 

       AC:

 

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;

double dis(double x1, double y1, double x2, double y2) {
        double xx = (x1 - x2) * (x1 - x2);
        double yy = (y1 - y2) * (y1 - y2);
        return sqrt(3) * sqrt(xx + yy) / 2;
}

int main () {
        int t;
        scanf("%d", &t);
        while (t--) {
                double x1, y1, x2, y2;
                double d;
                scanf("%lf%lf%lf%lf", &x1, &y1, &x2, &y2);
                d = dis(x1, y1, x2, y2);

                if (x1 == x2)
                        printf("(%.2f,%.2f)\n", x1 + (y1 > y2 ? d : -d), (y1 + y2) / 2);
                else if (y1 == y2)
                        printf("(%.2f,%.2f)\n", (x1 + x2) / 2, y1 + (x1 > x2 ? -d : d));
                else {
                        double a = (x1 + x2) / 2, b = (y1 + y2) / 2;
                        double k = (y1 - y2) / (x1 - x2);
                        double xa, xb, ya, yb;
                        xa = a + sqrt((k * k * d * d) / (1 + k * k));
                        xb = a - sqrt((k * k * d * d) / (1 + k * k));
                        ya = b - (xa - a) / k;
                        yb = b - (xb - a) / k;
                        y1 < y2 ? printf("(%.2f,%.2f)\n", xb, yb) :
                                  printf("(%.2f,%.2f)\n", xa, ya) ;
                }
        }
        return 0;
}

 

 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics