`
Simone_chou
  • 浏览: 185076 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

Task(贪心)

    博客分类:
  • HDOJ
 
阅读更多

Task

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1679    Accepted Submission(s): 428


Problem Description
Today the company has m tasks to complete. The ith task need xi minutes to complete. Meanwhile, this task has a difficulty level yi. The machine whose level below this task’s level yi cannot complete this task. If the company completes this task, they will get (500*xi+2*yi) dollars.
The company has n machines. Each machine has a maximum working time and a level. If the time for the task is more than the maximum working time of the machine, the machine can not complete this task. Each machine can only complete a task one day. Each task can only be completed by one machine.
The company hopes to maximize the number of the tasks which they can complete today. If there are multiple solutions, they hopes to make the money maximum.
 

 

Input
The input contains several test cases.
The first line contains two integers N and M. N is the number of the machines.M is the number of tasks(1 < =N <= 100000,1<=M<=100000).
The following N lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the maximum time the machine can work.yi is the level of the machine.
The following M lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the time we need to complete the task.yi is the level of the task.
 

 

Output
For each test case, output two integers, the maximum number of the tasks which the company can complete today and the money they will get.
 

 

Sample Input
1 2 100 3 100 2 100 1
 

 

Sample Output

 

1 50004

 

       题意:

       给出 N(1 ~ 100000)部机器,M (1 ~ 100000)个任务,每个任务只能由一部机器完成,每个机器只能完成一个任务,当机器的时间和难度值都大于任务的时间和难度值才能去完成任务。后给出 N 部机器的难度值和 M 部机器的时间和难度值。问如何安排能使完成的任务数最多且同样多的情况下获得的钱数最多。每次完成一个任务则获得 500 * 时间 + 2 * 难度值 的钱。

 

       思路:

       贪心。时间从大到小排序后,用任务去选择机器,挑出所有时间大于任务时间的机器中难度值大于任务且难度值最小的机器去完成。因为难度值最大才有 100,所以可以用数组统计机器的数量。记得钱数是 long long 的。

 

       AC:

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

typedef long long ll;

const int MAX = 100005;

typedef struct {
        int time, level;
} node;

node machine[MAX], task[MAX];

int level[105];

bool cmp (node a, node b) {
        if (a.time != b.time) return a.time > b.time;
        return a.level > b.level;
}

int main() {
        int n, m;

        while (~scanf("%d%d", &n, &m)) {

                for (int i = 0; i < n; ++i) {
                        scanf("%d%d", &machine[i].time, &machine[i].level);
                }

                for (int i = 0; i < m; ++i) {
                        scanf("%d%d", &task[i].time, &task[i].level);
                }

                sort(machine, machine + n, cmp);
                sort(task, task + m, cmp);

                memset(level, 0, sizeof(level));
                int ans = 0, mm = 0;
                ll sum = 0;
                for (int i = 0; i < m; ++i) {
                        while (mm != n && machine[mm].time >= task[i].time) {
                                ++level[ machine[mm].level ];
                                ++mm;
                        }

                        for (int k = task[i].level; k <= 100; ++k) {
                                if (level[k] > 0) {
                                        --level[k];
                                        ++ans;
                                        sum += 
                                            (ll)(task[i].time * 500 + 2 * task[i].level);
                                        break;
                                }
                        }
                }

                printf("%d %I64d\n", ans, sum);
        }

        return 0;
}

 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics