`
Simone_chou
  • 浏览: 184567 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

EXTENDED LIGHTS OUT(高斯消元)

    博客分类:
  • POJ
 
阅读更多
EXTENDED LIGHTS OUT
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 6552   Accepted: 4310

Description

In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right. 

The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged. 

Note: 
1. It does not matter what order the buttons are pressed. 
2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once. 
3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first 
four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off. 
Write a program to solve the puzzle.

Input

The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.

Output

For each puzzle, the output consists of a line with the string: "PUZZLE #m", where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1's indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.

Sample Input

2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0

Sample Output

PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1

 

       题意:

       给出 T 组样例,后给出一个 5 X 6 的矩阵,0 代表灯关,1 代表灯亮,每按一个键本身的灯和周围的四个相邻位置的灯也会改变状态,每组输出一个矩阵,该矩阵表示按或者不按的情况,1 代表按,0 代表不按,问要如何按灯使最终所有的灯都变成是关闭状态,即都变成 0。

 

       思路:

       高斯消元。要把所有的灯都变成 0,也可以反过来看,当所有灯为 0 的时候转变为所要求的灯的情况。

       列成 30 个 30 元 1 次方程,即每个灯的 0,1 情况用 a,b,c,d……表示,每按一个键都会有不同的状态,故把 30 种子状态(子矩阵)表示出来,将给出 30 个灯的状态转变为方程的右等式。后运用高斯消元求出答案即可。消元过程要运用到异或,因为只有 0,1 两种状态,异或 0,代表不改变当前灯的状况,异或 1 代表要该表当前灯的状态。

       详细过程:http://blog.csdn.net/u013081425/article/details/24452153

 

        AC:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>

using namespace std;

typedef vector<int> vec;
typedef vector<vec> mat;

mat res(30, vec(31));

void gauss_jordan() {
    for (int i = 0; i < 30; ++i) {
        int pivot = i;
        for (; pivot < 30; ++pivot)
            if (res[pivot][i]) break;
        swap(res[i], res[pivot]);

        for (int j = 0; j < 30; ++j) {
            if (i != j && res[j][i]) {
                for (int k = 0; k <= 30; ++k) {
                    res[j][k] = res[i][k] ^ res[j][k];
                }
            }
        }
    }
}

int main() {

    int t;
    scanf("%d", &t);

    for (int tt = 1; tt <= t; ++tt) {

        for (int i = 0; i < 5; ++i) {
            for (int j = 0; j < 6; ++j) {
                int ans = i * 6 + j;

                scanf("%d", &res[ans][30]);

                res[ans][ans] = 1;
                if (j - 1 >= 0) res[ans][ans - 1] = 1;
                if (i - 1 >= 0) res[ans][ans - 6] = 1;
                if (j + 1 < 6) res[ans][ans + 1] = 1;
                if (i + 1 < 5) res[ans][ans + 6] = 1;
            }
        }

        gauss_jordan();

        printf("PUZZLE #%d\n", tt);
        for (int i = 0; i < 5; ++i) {
            for (int j = 0; j < 6; ++j) {
                int ans = i * 6 + j;
                printf("%d", res[ans][30]);
                j == 5 ? printf("\n") : printf(" ");
            }
        }

    }

    return 0;
}

 

 

 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics