`
Simone_chou
  • 浏览: 183899 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

Nearest Common Ancestors(LCA 离线算法)

    博客分类:
  • POJ
 
阅读更多
Nearest Common Ancestors
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 18912   Accepted: 10007

Description

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below: 

 
In the figure, each node is labeled with an integer from {1, 2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is. 

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y. 

Write a program that finds the nearest common ancestor of two distinct nodes in a tree. 

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,..., N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input

2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5

Sample Output

4
3

 

     题意:

     给出 T 组 case,输入 N(2 ~ 10000),代表有 N 个结点,后输入 N -1 条边,最后询问 a 和 b 的最近公共祖先。

 

     思路:

     LCA。DFS + 并查集的离线算法。不需要保存每个节点对的最近公共祖先,只需要保存需要询问的结果就好了。建图的时候建成单向边,故 DFS 的时要找到根节点才开始往下。

 

      AC:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>

using namespace std;

const int VMAX = 10005;

int n, f ,t, res;
int ind[VMAX], root[VMAX];

vector<int> G[VMAX];

void init () {
    for (int i = 1; i <= n; ++i) {
        ind[i] = 0;
        root[i] = -1;
        G[i].clear();
    }
}

int Find (int x) {
    return x == root[x] ? x : root[x] = Find(root[x]);
}

void dfs (int u) {
    root[u] = u;

    for (int i = 0; i < G[u].size(); ++i) {
        int v = G[u][i];
        dfs(v);
        root[ Find(v) ] = Find(u);
    }

    if (u == f && root[t] != -1) res = Find(t);
    else if (u == t && root[f] != -1) res = Find(f);

}

int main() {

    int T;
    scanf("%d", &T);

    while (T--) {
        scanf("%d", &n);

        init();

        for (int i = 1; i <= n - 1; ++i) {
            int a, b;
            scanf("%d%d", &a, &b);
            G[a].push_back(b);
            ++ind[b];
        }

        scanf("%d%d", &f, &t);

        for (int i = 1; i <= n; ++i) {
            if (!ind[i]) dfs(i);
        }

        printf("%d\n", res);

    }

    return 0;
}

 

 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics