`
Simone_chou
  • 浏览: 185002 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

Prime Distance(素数区间筛选)

    博客分类:
  • POJ
 
阅读更多
Prime Distance
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11232   Accepted: 3018

Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers. 
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

 

    题意:

    给出 L,U (1<=L< U<=2,147,483,647),代表区间 [ L,U ],且U - L < 1,000,000。输出区间内的素数两连续距离最小的起点终点和最大的起点终点。

 

  思路:

  素数区间筛选。注意判断数的范围。

 

  AC:

#include <cstdio>
#include <string.h>
#include <algorithm>
#define MAX 1000005
using namespace std;

typedef long long ll;

int a,b,ans;
bool pri1[MAX],pri2[MAX];
int min_d,max_d,min_f,min_t,max_f,max_t;

void solve() {
    for(int i = 0;(ll)i * i < b;i++)    pri1[i] = true;
    for(int i = 0;i <= b - a;i++)       pri2[i] = true;
    pri1[0] = pri1[1] = false;

    for(int i = 2;(ll)i * i <= b;i++) {  
            if(pri1[i]) {
                    for(int j = i;(ll)j * j * i * i <= b;j++) 
                        pri1[i * j] = false;

                    for(ll j = max((ll)2,((ll)a + i - 1) / i) * i;j <= b;j += i)
                        pri2[j - a] = false;
            }
    }

    if(a == 1) pri2[0] = false; //若左区间等于1,要另外判断

    int last;
    ans = 0;min_d = MAX;max_d = -1;

    for(int i = 0;i <= b - a;i++) {
            if(pri2[i]) {
                    if(ans) {
                            if(i - last < min_d) {
                                    min_d = i - last;
                                    min_f = last;
                                    min_t = i;
                            }
                            if(i - last > max_d) {
                                    max_d = i - last;
                                    max_f = last;
                                    max_t = i;
                            }
                    }
                    last = i;
                    ans++;
            }
    }

}

int main() {
    //freopen("test.in","r",stdin);

    while(~scanf("%d%d",&a,&b)) {
            solve();
            if(ans <= 1) puts("There are no adjacent primes.");
            else printf("%d,%d are closest, %d,%d are most distant.\n"
                        ,min_f + a,min_t + a,max_f + a,max_t + a);
    }

    return 0;
}

 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics