`
Simone_chou
  • 浏览: 184565 次
  • 性别: Icon_minigender_2
  • 来自: 广州
社区版块
存档分类
最新评论

Humble Numbers(技巧)

    博客分类:
  • HDOJ
 
阅读更多

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16312    Accepted Submission(s): 7082


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence
 

 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

 

Sample Input
1
2
3
4
11
12
13
21
22
23
100
1000
5842
0
 

 

Sample Output

 

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

 

        题意:

        也同样是找第 N 个丑数。质因子只允许是 2, 3, 5, 7。

 

        思路:

        与 USACO 那题一样。坑爹的地方在于输出,第1,2,3 个要输出 st,nd,rd。但是 11,12,13 却不用,判断的时候应该判断 n % 10 == 1 && n % 100 != 11 这样子判断。并且结果要离线处理好。

 

        AC:

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

typedef long long ll;

const ll INF = 5000000000;

int p[5], f[5];
ll hum[6000];

void solve () {
        p[1] = 2, p[2] = 3, p[3] = 5, p[4] = 7;
        for (int i = 1; i <= 4; ++i) f[i] = 1;

        hum[1] = 1;
        for (int k = 2; k <= 5842; ++k) {
                ll Min = INF;
                for (int i = 1; i <= 4; ++i) {
                        while (p[i] * hum[ f[i] ] <= hum[k - 1]) ++f[i];
                        Min = min(Min , p[i] * hum[ f[i] ]);
                }

                hum[k] = Min;
        }
}

int main() {

        solve();

        int n;

        while (~scanf("%d", &n) && n) {
                printf("The %d", n);
                if (n % 10 == 1 && n % 100 != 11) printf("st ");
                else if (n % 10 == 2 && n % 100 != 12) printf("nd ");
                else if (n % 10 == 3 && n % 100 != 13) printf("rd ");
                else printf("th ");
                printf("humble number is %lld.\n", hum[n]);
        }

        return 0;
}

 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics